Unconfigured Ad Widget



No announcement yet.

SGC microJukebox

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • SGC microJukebox


    The Problem: Your collection of Music CDs are collecting dust. Your CD Changer died or your CD Player seems to only work every second Tuesday of the month. Maybe a few lucky CDs have made it to your car where they see limited action, living out their meager existence in the glove box. All that music, just waiting to be heard.

    You may have moved on to something like a Sonos® audio speaker system and begun to repurchase the same great music you love, one painful download at a time.

    Maybe you've downloaded your music onto your PC. A directory full of MP3 files that sound mediocre at best.

    Well stop, we have a better alternative...

    The microJukebox was created to bring all of your Music CDs back to life. Turn in your old CD Player / CD Changer for 21st century solution that you will be proud to own. Escape the musical dark ages with the latest in music technology...

    Solution: The microJukebox is a low power, Music Server NAS (Network Attached Storage) that will automatically rip Music CDs to its internal hard drive and serve them up to your network player or locally attached DAC.

    What does this mean?: All of your music is once again easily accessible. Musical Freedom.

    You can also finally dispose of that old CD Changer and join the microJukebox revolution.

    Remember that Sonos speaker you bought. The microJukebox seamlessly integrates with Sonos in seconds. Happy days are here again!

    Small Green Computer
    | sonicTransporter | microJukebox | Linear Power Supplies | Inakustic | Accessories | Software |

  • #2
    i tried adding a usb hard disk to my microjukebox and could not get it to work so I tried power on and off. I did finally get it to mount and that was all. I could not find a way to access the hard disk. Then for some reason the microjukebox went offline. Calling up the IP address through a browser said it did not respond. Can anybody help? I hope this is the right place to post.